motor mount threads stripped?

Discussion in 'General Motoring' started by callen1155, Dec 28, 2005.

  1. callen1155

    callen1155 Guest

    Hello,

    My son has a 94 SC1.

    The motor mount on the top passenger side of engine (Torque Axis
    Mount) threads in the engine are stripped, all three of them. That side
    of the engine just drops down and rests on the frame. The bolts are ok
    but the threads in the block are stripped.

    He called the Saturn dealer and they want $157 to retap it.
    I didn't speak to them so I'm not sure of the precedure they would use.
    (that is, would they drill and tap to a larger diameter bolt, etc).

    Has anyone encounted this and attempted to fix it themselves?

    Thanks for any advice.

    chuck
     
    callen1155, Dec 28, 2005
    #1
    1. Advertisements

  2. callen1155

    Private Guest

    Google "helicoil"
    http://www.roadstarmagazine.com/modules.php?name=News&file=article&sid=233

    happy landings,
     
    Private, Dec 29, 2005
    #2
    1. Advertisements

  3. Do not helicoil it. It is very brittle aluminum that holds alot of weight.
    Do you plan on doing it yourself? If so, just change the timing cover with
    a new/used on with good threads. You can find them cheap at junk yards or
    on saturn message boards...... Maybe $50 or so. Would take maybe 2-3 hours
    if you havent done it before. And you dont have to touch ANY timing parts,
    just the cover.
     
    TheLastDonSC2, Dec 29, 2005
    #3
  4. callen1155

    callen1155 Guest

    Thanks. Thats a good plan. I'll see if we can find a used timing cover.
    Sounds much better than the helicoil fix.
     
    callen1155, Dec 29, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.