EGR value

Discussion in 'General Motoring' started by peterpan, Nov 30, 2004.

  1. peterpan

    peterpan Guest

    I have just change the egr valve and the o2 sensor. But when it get cold
    code 13, 32 again, and I just change the map sensor. If it warmer the
    errors seem to not show up.
    95 SL1 Single cam
    Please help ..
     
    peterpan, Nov 30, 2004
    #1
    1. Advertisements

  2. peterpan

    Bob Shuman Guest

    I don't remember if the EGR solenoid on the '95 is vacuum or electrically
    activated. having said that, I'd suggest you make sure that the vacuum hose
    is not cracked or leaking if it is the former. In fact at that age, I'd
    make sure that all the vacuum hoses are good since a leak in any would
    reduce vacuum in others. Also, when you had the EGR valve off, did you
    notice if the exhaust manifold or intake was plugged which could affect
    proper operation?

    Good luck.

    Bob
     
    Bob Shuman, Nov 30, 2004
    #2
    1. Advertisements

  3. peterpan

    peterpan Guest

    Yes, the EGR solenoid is electrically on the 95. I check the manifod intake
    is see. When I changed it I looked but not very closly to see if the was
    pluged up. What confused me is that check engine light turns on when it
    is cold out side?

    Thanks for the help...
     
    peterpan, Dec 1, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.