code 94 - idle speed too high

Discussion in 'General Motoring' started by chuck smoko, Oct 18, 2004.

  1. chuck smoko

    chuck smoko Guest

    Hi,
    I have a 94 SL1 w/ standard transmission. I got a
    check engine light and the reveled code is a 94, which
    is idle speed too high (vacuum leak). I checked
    around and saw no obvious "hose off" or anything.
    Just for grins, I replaced the PCV and grommet as
    well as a "not so clean" air filter. The PCV had a real-
    ly sloppy fit into the valve cover. However, I am still
    getting the check engine and code 94. If I am at a
    stop light and sitting there idling, the engine will speedup
    for a few and check engine will illuminate. Anyone seen
    this and solved this problem?

    chuck
     
    chuck smoko, Oct 18, 2004
    #1
    1. Advertisements

  2. chuck smoko

    Blah blah Guest

    EGR maybe. The replacement PCV parts not OEM?
     
    Blah blah, Oct 18, 2004
    #2
    1. Advertisements

  3. I'd pull the throttle body and give it a good cleaning while you're at
    it. Might have a gummed up IAC, and that can do interesting things...
     
    Philip Nasadowski, Oct 19, 2004
    #3
  4. chuck smoko

    chuck smoko Guest

    Phipip,
    What is a IAC?

    chuck

     
    chuck smoko, Oct 20, 2004
    #4
  5. Idle Air Control

     
    Jonnie Santos, Oct 20, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.