94 sc2 Power Steering Pump

Discussion in 'General Motoring' started by stevengupta, Jan 12, 2006.

  1. stevengupta

    stevengupta Guest

    I just recently tried to change the power steering pump on my saturn.
    It seemed pretty easy for the most part. I used a reman and had to swap
    off the pulley, bottle, and actuator. After getting it back together
    the steering was very hard to turn. After a while I decided to put the
    old pump on, same thing, I must have turned the wheel from lock to lock
    while the car was up on stands about 30 times and makes no difference.
    In fact when the engine is not running its easier to turn the wheel.
    The only thing I can think of is something is wrong with the actuator.
    Anyone have any ideas?
     
    stevengupta, Jan 12, 2006
    #1
    1. Advertisements

  2. Hoses backwards?
     
    Philip Nasadowski, Jan 13, 2006
    #2
    1. Advertisements

  3. stevengupta

    stevengupta Guest

    One hose goes to the bottle with a clamp the other is a high pressure
    hose with a fitting.
    Would be impossible to mismatch those considering I didn't remove them
    from the rack.
     
    stevengupta, Jan 13, 2006
    #3
  4. stevengupta

    SixthSphere Guest

    I missed the original post... what was the problem?

    Brian
    a.k.a. ProjectSW1
     
    SixthSphere, Jan 13, 2006
    #4
  5. stevengupta

    stevengupta Guest

    power steering isn't working after switching out the pump.
     
    stevengupta, Jan 13, 2006
    #5
  6. stevengupta

    Fred V. Guest

    Hi
    What was wrong with the old pump?
    No problems with mine yet.
    Fred
    '94 SC2
     
    Fred V., Jan 20, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.