Saturn Car Forums


Reply
Thread Tools Display Modes

1995 Saturn SL2

 
ysone
Guest
Posts: n/a
 
      10-05-2004
I have a 95 Saturn, with a 98 DOHC engine and trans. It has been running
great for six months til lately. It has developed a no power situation.
When it goes into 3rd gear (auto) it surges. When I rev the engine up in
neutral it is fine. Also top speed is 50 mph on the floor. It slows down
considerable going up a hill and will not downshift. I have replaced the
fuel filter, plug wires, plugs, air filter, changed oil and filter, and
serviced the trans, accessed the computer and it has a repeating code
12.(ok)
I checked fuel pump pressure and I have 35psi at the access fitting at the
engine. I have been told it might be a clogged converter. It seems to blow
exhaust fine when rev'ed up. The exhaust does not smell (like rotten
eggs), but the exhaust appears to be real hot. I have not checked the EGR
yet. It seems like it is dragging an anchor. I appreciate any help.

 
Reply With Quote
 
 
 
 
TSMANGOD
Guest
Posts: n/a
 
      10-06-2004
>
>I have a 95 Saturn, with a 98 DOHC engine and trans. It has been running
>great for six months til lately. It has developed a no power situation.
>When it goes into 3rd gear (auto) it surges. When I rev the engine up in
>neutral it is fine. Also top speed is 50 mph on the floor. It slows down
>considerable going up a hill and will not downshift. I have replaced the
>fuel filter, plug wires, plugs, air filter, changed oil and filter, and
>serviced the trans, accessed the computer and it has a repeating code
>12.(ok)
>I checked fuel pump pressure and I have 35psi at the access fitting at the
>engine. I have been told it might be a clogged converter. It seems to blow
>exhaust fine when rev'ed up. The exhaust does not smell (like rotten
>eggs), but the exhaust appears to be real hot. I have not checked the EGR
>yet. It seems like it is dragging an anchor. I appreciate any help.


I had something similar happen on my 96, but after dealing with it for a
while, it became very loudly apparent what the trouble was. The brakes were
sticking. I changed all 4 calipers, and rotors and pad/shoes (I can never
remember which is which), and it goes, now.
If you let go of the gas pedal, does it slow down very quickly? If you put
it in drive and don't push the gas, will you move? These tests are one way to
find out. Or you could let the Dealer tell you, for about $80, just to look.
I'm cheaper.
Good luck,
Tedrick
 
Reply With Quote
 
 
 
 
Jonnie Santos
Guest
Posts: n/a
 
      10-06-2004
....Is the Service Engine Light coming on, and how do you know the exhaust is
running "real hot"? (just curious) Sounds like a trip to the dealer, eh?

"ysone" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) lkaboutautos.com...
>I have a 95 Saturn, with a 98 DOHC engine and trans. It has been running
> great for six months til lately. It has developed a no power situation.
> When it goes into 3rd gear (auto) it surges. When I rev the engine up in
> neutral it is fine. Also top speed is 50 mph on the floor. It slows down
> considerable going up a hill and will not downshift. I have replaced the
> fuel filter, plug wires, plugs, air filter, changed oil and filter, and
> serviced the trans, accessed the computer and it has a repeating code
> 12.(ok)
> I checked fuel pump pressure and I have 35psi at the access fitting at the
> engine. I have been told it might be a clogged converter. It seems to blow
> exhaust fine when rev'ed up. The exhaust does not smell (like rotten
> eggs), but the exhaust appears to be real hot. I have not checked the EGR
> yet. It seems like it is dragging an anchor. I appreciate any help.
>



 
Reply With Quote
 
ysone
Guest
Posts: n/a
 
      10-06-2004
No service engine light. The computer shows clear. I used a infared
pyrometer and compared to another Saturn it seems to be running 100-150
degrees higher. I drove the car again and it does not slow down fast. On a
flat road it takes about a half mile to reach 50mph, and that is all it
will do. I jacked up the car and checked the brakes and they are free, non
appears to be sticking nor is the car pulling due to sticking calipers. I
also checked the compression and all of the cyls are within 5 lbs of
factory specs. I am leaning toward a blockage in the exhaust(converter).I
am hoping to avoid a trip to the dealer, but if I must, I will. Thanks for
the input.

 
Reply With Quote
 
Napalm Heart
Guest
Posts: n/a
 
      10-06-2004

"ysone" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) lkaboutautos.com...
> I have a 95 Saturn, with a 98 DOHC engine and trans. It has been

running
> great for six months til lately. It has developed a no power

situation.
> When it goes into 3rd gear (auto) it surges. When I rev the engine

up in
> neutral it is fine. Also top speed is 50 mph on the floor. It slows

down
> considerable going up a hill and will not downshift. I have

replaced the
> fuel filter, plug wires, plugs, air filter, changed oil and filter,

and
> serviced the trans, accessed the computer and it has a repeating

code
> 12.(ok)
> I checked fuel pump pressure and I have 35psi at the access fitting

at the
> engine. I have been told it might be a clogged converter. It seems

to blow
> exhaust fine when rev'ed up. The exhaust does not smell (like rotten
> eggs), but the exhaust appears to be real hot. I have not checked

the EGR
> yet. It seems like it is dragging an anchor. I appreciate any help.
>


A plugged converter can be dangerous (FIRE). I'd make that the very
next check.

Ken


 
Reply With Quote
 
Shawn
Guest
Posts: n/a
 
      10-06-2004
plugged converter will cause that. I had an old car once that did that and
it was the converter. I had it taken off and this fixed the peoblem.
"ysone" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) lkaboutautos.com...
> I have a 95 Saturn, with a 98 DOHC engine and trans. It has been running
> great for six months til lately. It has developed a no power situation.
> When it goes into 3rd gear (auto) it surges. When I rev the engine up in
> neutral it is fine. Also top speed is 50 mph on the floor. It slows down
> considerable going up a hill and will not downshift. I have replaced the
> fuel filter, plug wires, plugs, air filter, changed oil and filter, and
> serviced the trans, accessed the computer and it has a repeating code
> 12.(ok)
> I checked fuel pump pressure and I have 35psi at the access fitting at the
> engine. I have been told it might be a clogged converter. It seems to blow
> exhaust fine when rev'ed up. The exhaust does not smell (like rotten
> eggs), but the exhaust appears to be real hot. I have not checked the EGR
> yet. It seems like it is dragging an anchor. I appreciate any help.
>



 
Reply With Quote
 
saturn_SL2
Guest
Posts: n/a
 
      10-10-2004
if it acts up after warming up try the two temp sending units on the side
of the head


 
Reply With Quote
 
ysone
Guest
Posts: n/a
 
      10-11-2004
Thanks for the help guys, but here's the latest. I changed the
converter......same problem. I checked the OBD again. No trouble codes. I
have heard that this model has a transmission mounted speed sensor and
amplifier that feeds input the the computer, and that if this goes bad it
could cause problems. Has anybody ever heard of this? This problem happens
hot or cold. I changed the temp sensors in the head....still same problem.
Saturn dealership is no help when I call to ask for advice, they would
rather have me bring it in and charge me for something that I could
probably fix myself. At my wits end!

 
Reply With Quote
 
mcgheen2
Guest
Posts: n/a
 
      10-21-2004
Im a mechanic @ a Saturn dealer and I have a 95. I had a similar problem
when I rebuilt the motor, I swaped out the intake with a newer one because
it was cleaner (less work). But infact it was more work, the injectors in
a 95 only work with a 95(because of the wiring harness and computer). It
has something to do with the resistance in them. Mine wouldnt pickup right
away and had some accel prob only in gear, and I tracked it down to the
injectors. I put my old 95 injectors on, and wallah it works fine. I cant
gurantee that this will work but id give it a shot if you still have ur old
95 injectors laying around! =)

 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Saturn SL2 - antifreeze leak troubleshooting and brake bleeding?? Woogeroo Saturn S-series 2 12-28-2005 10:41 AM
1995 saturn sl2 crank but wont start Jon A via CarKB.com Saturn S-series 2 06-21-2005 01:37 AM
Saturn Clock/Radio Light Repair 1995 SL2 Don Saturn S-series 0 02-20-2004 02:22 AM
1995 Saturn SL2 Repairs Jeremy Byrn Saturn S-series 3 09-04-2003 12:55 AM
1995 Saturn SL2 - A/C problems - questions Woogeroo Saturn S-series 3 07-24-2003 01:08 AM


All times are GMT. The time now is 07:14 PM.